• 24.04.2014, 02:46
  • Register
  • Login
  • You are not logged in.

 

Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Mainboard HDD LED Flasher/Erweiterung

Wednesday, April 18th 2012, 11:05pm

Guten Abend, ich bin richtig frustriert das ich nicht mehr weiter komm aber nunja ohne Hilfe wirds einfach nichts :)

Erstmal zu meinem Projekt: Ich möchte den HDD LED Anschluss meines Mainboards abgreifen, verstärken und schluss endlich 4 Leds's ansteuern die auch in der helligkeit geregelt werden können (quasi falls der rechner nachts laufen muss ich aber schlafen will damits nich so hell iss xD naja eigentlich kommt da nochn schalter zwischen der zwischen hdd flash-dauerlicht-aus da iss )

Ich habe mich lange damit befasst etliches nachgebaut und eigentlich iss alles inne Hose gegangen.

Als ich noch etwas bei verstand war habe ich mir ne schaltung ausgedacht und wollte die irgenwann mal bauen, nunja das ist etwa ein halbes jahr her und ich weiss nichtmal mehr wozu welches bauteil eigentlich da war, echt traurig und ich mach ne ausbildung zum elektroniker :(

Um es anders zu formulieren ich wäre froh wenn mir jemand helfen würde, meine nerven sin im moment nich die besten und nunja ich weiss nichtmal mehr wie man ein datenblatt liest. alles vergessen -.-

Anbei mal meine Schaltung als Anhang in Multisim. Lochmaster habe ich auch und Eagle werde ich wohl nie verstehen.

Vllt kann mir jemand helfen ob ich da was richtig oder falsch gemacht habe, die überlegung war erstmal das ein mainboard keine spannunsquelle ist sondern an beiden pins +5V hat. Einer der Pins wird negativer sprich mehr auf masse gezogen wenn die festplatte aktivität hat, dadurch entsteht zwischen beiden pins eine spannungsdifferenz und damit steuert jedes mainboard eine normale LED an.

Ich habe einen Optokoppler genommen (wieso weiss ich nichtmehr vllt entkoppeln kp) scheinbar iss davor nen widerstand xD ehrlich ich weiss nichmehr wieso joa und dan gehts ab zu nem mosfet.

Dankeschön :)
Knochenjonny has attached the following file:

Wednesday, April 18th 2012, 11:33pm

Erstmal herzlich Wilkommen in der Beklopptenbande :P :thumbsup: ;)

Kannst du mal ein Bild von der Schaltung posten, denn ich habe leider nur Eagle ^^
Fährste quer, siehste mehr! :D

Wednesday, April 18th 2012, 11:38pm

Kein Problem, das mit dem Bekloppt ist garnicht so abwägig wenn bedenkt was grade mit mir los ist >_>

Edit: Mir ist eingefallen wozu das zweite Poti da ist (das bei den LED's, das dient dazu um den mosfet zu überbrücken, der strom geht ja bekanntlich den weg des geringsten widerstandes, deswegen ist es so das wenn ich an diesem poti stelle in der theorie die leds bereits immer leuchten bzw je nach einstellung glimmen das war auch sinn und zweck, leds sollen immer schon etwas blau leuchten und wenn die platte aktiv wird und durchgeschaltet wird dann blitzen sie richtig auf) Fragt bloss nich wie die in meinem gehäuse angeschlossen sind xD die leds sitzen inner fronttür, und diese hatt oben und unten eine blechschraube und anner gehäuse innenseite sind zwei magnete, die magnete haben die vorsorgungsspannung 12v oder 5v bin mir noch nicht sicher, und wenn die tür zu iss leuchtets wenn se auf iss nicht xD
Knochenjonny has attached the following image:
  • Unbenannt.jpg

This post has been edited 1 times, last edit by "Knochenjonny" (Apr 18th 2012, 11:43pm)

Thursday, April 19th 2012, 9:14pm

Puhhhh also irgendwie komme ich mit deinem Plan nicht ganz so zurecht xD. Da muss jemand ran, der sowas schon länger macht ;)
*zu lotadac und limbachnet rüber schiel* :D

ABER,
ich hätte noch eine Version für dich, für die man nur wenig Bauteile braucht und definitiv funktioniert (schon 3x gebaut). Nur fehlen hier noch die Vorwiderstände der LEDs ;).
Um die LEDs jetzt zu dimmen könnte man versuchen zusätzlich zu den Vorwiderständen einen Poti ein zu bauen. Damit könnte man den Widerstand erhöhen, wodurch die LEDs in der Theorie dunkler sein sollten.
Allerdings habe ich das noch nicht getestet. Den Wert des Potis müsste man auch durch testen ausprobieren, nur habe ich zur zeit leider keine hier.

Fals das nicht geht müsste man vielleicht einen PWM Dimmer nehmen, allerdings ist das ein wenig aufwendiger.

MfG
Sascha :)
Sappibaer has attached the following image:
  • hdd flasher.png
Fährste quer, siehste mehr! :D

Thursday, April 19th 2012, 10:46pm

Ähm....
mal ne dumme frage:
sind 4 LEDs zu viel für den Anschluss?
4*0,02A = 0,08A => 0,216 W...

Wenn nicht... die Schaltungen scheinen mir arg kompliziert... Warum keinen kleinen NPN Transistor mit nem Poti, nen Vorwiderstand oder so...
Fürchtet den furchtbaren Fluch des Finsterwald-Fuchses!

drdeath

Senior Member

Thursday, April 19th 2012, 11:11pm

Aaaaalso. Erst mal- Die LED werden bitte seriell geschaltet und nicht parallel, da werden sie nacheinander durchbrennen, da sie ihren Strom nicht steuern können und du nie vier genau gleiche finden wirst.
Dann: Vergiss den dussligen Optokopler. Was du brauchst ist ein simpler Mosfet und ein hochohmiger Spannungsteiler. JA, das kannst du machen - Der ganze PC hat nur eine Masse, d.h. du bekommst keine Potentialverschiebung dadurch. NEIN, da fließt kein Strom in die falsche Richtung, das passiert nur bei JFet, bei MOSFet ist das Gate komplett von der S-D-Strecke isoliert. Im übrigen würd ich erst mal versuchen die vier LED einfach hintereinanderzulöten und an den LED-anschluss anzuschließen. Da die Durchlassspannungen der Power-LED sehr unterschiedlich sind - Du kannst nach wie vor an jedes Mainboard gefahrlos eine 1.6V-Standard-Red wie auch eine 5V-Superbright-Blue anschließen - haben die meisten Boards da eine kleine Konstantstromquelle. Und da sich bei Serieller Verdrahtung der Strom nicht ändert... Schau einfach mal, ob das Board dir die nötige Spannung gibt, um alle vier seriell zu betreiben. Wenn nicht, kannste immer noch auf die Geschichte mit dem Mosfet zurückgreifen.
Herr, gib mir die Kraft zu ertragen was ich ertragen muss und den Mut zu ändern was ich ändern kann - aber gib mir um gotteswillen auch eine Schaufel, damit ich den Rest erschlagen und vergraben kann...
Hier geht's zum RGBAmp

Friday, April 20th 2012, 7:33am

Vielen dank erstmal für die schnellen Antworten.
Ich Blick mittlerweile wieder durch bei meiner Schaltung und die sollte eigentlich sehr gut funktionieren.

Vom Mainboard gehe ich auf den Optokoppler soweit klar, dieser dient NUR als Sicherheit zur Galvanischen trennung (Da alle meine Mainboards über 300 Euro kosten werde ich dieses Bauteil definitiv nicht weglassen xD) Der Vorwiderstand am Optokoppler ist dringend anzuraten da dieser sonst keine Strombegrenzung hat und irgendwan einfach kaputt geht. Der OK bekommt nun also die Mainboard Pins (beide haben 5V, misst man mit einem Multimeter bei inaktiver HDD erhält man 0V da keine Differenz vorliegt), wenn nun die HDD Aktiv wird wird ein PIN auf masse gezogen und es ensteht eine Spannungsdifferenz, dadurch Leuchted die Fotodiode im OK und schaltet den Transistor durch.

Am Ausgang des OK hängt der Leistungs FET (ein FET deswegen da dieser nicht wie ein Transistor träge schaltet sondern schlagartig und ohne Verluste) 5k sind als vorwiderstand. Schaltet nun der BUZ11 durch leuchten die LED's. Zusätzlich habe ich einen Spannungsteiler parrallel zum FET, Ich greife vom Leistungspoti den Mittelabgriff ab und falls über die FET strecke nichts kommt (quasi wenn HDD nichts macht), dann kann ich über diesen Zweig einstellen das die LED's trotzdem Leuchten und diese in der Helligkeit regeln.

Poti 10k 100%= LED's volle Helligkeit, + HDD Aktivität = Keine Auswirkung leds bleiben wie sie sind (heller gehts ja nicht ^^)
Poti 10k vllt, 80%= LED's zb. mittelhell + HDD Aktivität = Kurzzeitig Max Helligkeit (solange die HDD halt aktiv ist, meistens ist das ja nur son aufblitzen da ziemlich kurz).

Die Schaltung wollte ich erst mit einem PIC Realisieren hatte auch schon einen gekauft (quasi als Schwellwertschalter) ABER da die Pins am Mainboard eben nicht + und - sind Hätte ich die Hystere nicht vernünftig realisieren können ergo zuviel aufwand beim Programmieren.

xD So damit sollte das erstmal erledigt sein ^^ demnächst werde ich es aufbauen aber eventuell noch anders, mittels eines Arrays könnte ich einfach nach dem OK alles weglassen und bräuchte nurn IC der bei HDD aus die oberen 4 ausgänge schaltet und bei HDD ein die unteren Vier, Dazu nehme man 4 Duo LED's (rot und Blau sieht schick aus ^^) schliesse jeweils nur Cathoden von Blau zb. an die ersten pins und rot an die letzten an und viola die Farbe ändert sich nach der Festplatte xDDDDDD

Friday, April 20th 2012, 8:12am

Erstmal 'ne Frage an den Doc:
Warum sollen die LEDs nacheinander durchbrennen? Vielleicht kann ich es mit meiner medizinischen Ausbildung ja nicht sehen - erklärs mir bitte. Ich hab schließlich keine Ahnung von Elektronik und so. Aber mMn sollten die Vorwiderstände vor den LEDs doch jeweils den Strom durch selbige begrenzen, oder? Bei einem angenommenem Spannungsabfall von 1,2V an den LEDs würde der Strom durch den Widestand auf ca 25mA begrenzt werden. In jedem Zweig.
Warum kommt mir eigentlich nahezu jeder Post von Dir so agressiv vor?

Zum Thema: sollte zwischen Optokoppler und Gate des FET nicht noch ein Widerstand? der FET braucht den nicht, aber verkraftet der CNY die (eben noch nicht begrenzten) Stromspitzen beim Umladen der Gate-Kapazität? AFAIK verträgt der CNY sekundär 50mA, 100mA peak.

Zum MoBo-Anschluß und Vorwiderstand: wie bereits mehrfach gesagt, sollte es sich hier bereits um eine Stromquelle handeln - wenn eine 20-30mA LED da nicht durchbrennen soll, wird wohl auch die (auf max 60mA ausgelegte) IR-LED im Optokoppler damit klarkommen. Genau genommen sollte die Stromquelle mit dem 330R bereits jenseits ihrer Regelgrenzen sein (wenn man mal 20mA und max 5V annimmt). Selbst ohne Optokoppler. Es wird also dauerhaft auf 5V geregelt, ohne den angestrebten Strom erreichen zu können.
Eheim1046->AD->CPU->NB->GraKa-APE240->AT AMD Sempron2500@2090MHz-K7VT4A+FSB333@380MHz-Maxtor80GB-Nvidia Geforce FX 5500

drdeath

Senior Member

Friday, April 20th 2012, 9:04pm

Erstmal 'ne Frage an den Doc:
Warum sollen die LEDs nacheinander durchbrennen? Vielleicht kann ich es mit meiner medizinischen Ausbildung ja nicht sehen - erklärs mir bitte.
Aber natürlich, mein lieber LotadaC, das erkläre ich dir gerne. Bauteile haben eine Fertigungstoleranz, klar soweit? Wenn du nun mehrere Ohm'sche Verbraucher parallel schalten würdest, würde das nichts ausmachen - kriegt halt einer ein bissel mehr Strom ab, der andere bissel weniger. Nun sind LED aber keine Ohm'schen Bauteile und können ihren Strom NICHT selbst steuern, daher der Vorwiederstand. Soweit isses sicher noch plausibel. Wenn du mehrere LED an einen Vorwiderstand hängst, begrenzt der den GESAMTStrom - Den die LED dann unter sich aufteilen - bei idealen Bauteilen, die genau gleich sind, genau gleich. Und genau da hängt der Hammer- nu sind aber reale Bauteile wie gesagt nicht ideal. Es wird immer eine LED geben, die etwas - für den Laien ausgedrückt - niederohmiger ist als die anderen. Die bekommt dann logischerweise einen überproportional hohen Strom ab. So weit so gut, kein Problem, isse halt bissel heller als die anderen - denkst Du als Laie. Nu kommt aber der Clou an der Sache: Je wärmer eine Diode wird, desto schneller altert sie. Je mehr sie altert, desto mehr Strom lässt sie durch. Und je mehr Strom sie durchlässt, desto wärmer wird sie. Merkst du was? Nein du merkst zunächst erst mal wenig, wenn nicht eine LED völlig aus dem Rahmen fällt. Allerdings in ein paar Wochen fällt dir auf, dass die eine LED immer heller wird, und die anderen immer dunkler. Und nu kommt der nächste Hund daher: Wenn eine Led stirbt, brennt sie i.d.R zu, d.h. sie wird nicht leitend. Mit anderen Worten: sobald die erste stirbt, bekommen die anderen deren Strom mit ab. Von denen wieder eine die "schwächste" ist, d.h. das Spiel wiederholt sich, nur viel schneller. Ander ausgedrückt: du überlegst dir abends, "morgen muss ich mal beim Conrad vorbei und ne neue LED holen" und am nächsten Morgen sind schon alle vier, sechs, zehn wieviele du hast hattest durch.

Warum passiert das nu bei Reihenschaltung nicht? Ganz einfach: in einer Reihenschaltung, so haben wir es alle im Physikunterricht gelernt, ist der Strom an jeder Stelle gleich. Sollte nu also eine Diode dabei sein, die etwas durchlässiger ist als die anderen, macht das nix - Der Strom muss schön im Gänsemarsch durch und kann sich nicht auf das schwächste Glied der Kette konzentrieren.

Quoted

Warum kommt mir eigentlich nahezu jeder Post von Dir so agressiv vor?
Ja nu - DAS weiss ICH ja nu nicht, die Frage musste dir schon selbst beantworten.
Herr, gib mir die Kraft zu ertragen was ich ertragen muss und den Mut zu ändern was ich ändern kann - aber gib mir um gotteswillen auch eine Schaufel, damit ich den Rest erschlagen und vergraben kann...
Hier geht's zum RGBAmp

Friday, April 20th 2012, 10:29pm


. Wenn du mehrere LED an einen Vorwiderstand hängst, begrenzt der den GESAMTStrom - Den die LED dann unter sich aufteilen - bei idealen Bauteilen, die genau gleich sind, genau gleich.
Wo steht hier was von einem Vorwiderstand?


Aber mMn sollten die Vorwiderstände vor den LEDs doch jeweils den Strom durch selbige begrenzen, oder? Bei einem angenommenem Spannungsabfall von 1,2V an den LEDs würde der Strom durch den Widestand auf ca 25mA begrenzt werden. In jedem Zweig.


Warum kommt mir eigentlich nahezu jeder Post von Dir so agressiv vor?



agressiv kann ich bestätigen.
Das sind keine Schreibfehler nur Krümel in der Tastatur.

Friday, April 20th 2012, 11:44pm

...die Vorwiderstände vor den LEDs doch jeweils den Strom durch selbige begrenzen, oder? ...

Vielleicht hätte ich das auch in Schriftgröße 36 rot-blinkend schreiben sollen - mMn war der Plural klar zu erkennen...
Eheim1046->AD->CPU->NB->GraKa-APE240->AT AMD Sempron2500@2090MHz-K7VT4A+FSB333@380MHz-Maxtor80GB-Nvidia Geforce FX 5500

Saturday, April 21st 2012, 1:08am

Quoted

agressiv kann ich bestätigen.
vielleicht etwas zynisch, vielleicht auch etwas sarkastisch, aber aggressiv denk ich nich :<
Fürchtet den furchtbaren Fluch des Finsterwald-Fuchses!

drdeath

Senior Member

Sunday, April 22nd 2012, 6:37pm

...die Vorwiderstände vor den LEDs doch jeweils den Strom durch selbige begrenzen, oder? ...

Vielleicht hätte ich das auch in Schriftgröße 36 rot-blinkend schreiben sollen - mMn war der Plural klar zu erkennen...


Sind wir jetzt hier im Kindergarten oder was? In obigem Schaltplan sind die LED OHNE individuelle Vorwiderstände Parallel geschaltet. Darauf bezog ich mich - offensichtlicherweise. Wie ich dir sehr ausführlich schrieb, bezieht sich das von mir gesagte auf die parallele Verschaltung mehrerer LED an einem gemeinsamen Strombegrenzer. Soll ICH dir das in Großschrift schreiben oder vielleicht ein Buildl dazu malen? Himmelarschundzwirn...
Herr, gib mir die Kraft zu ertragen was ich ertragen muss und den Mut zu ändern was ich ändern kann - aber gib mir um gotteswillen auch eine Schaufel, damit ich den Rest erschlagen und vergraben kann...
Hier geht's zum RGBAmp

Sunday, April 22nd 2012, 6:39pm

Meinst du in meinem Plan?
Fährste quer, siehste mehr! :D

Sunday, April 22nd 2012, 8:47pm

...Sind wir jetzt hier im Kindergarten oder was? In obigem Schaltplan sind die LED OHNE individuelle Vorwiderstände Parallel geschaltet. Darauf bezog ich mich - offensichtlicherweise. Wie ich dir sehr ausführlich schrieb, bezieht sich das von mir gesagte auf die parallele Verschaltung mehrerer LED an einem gemeinsamen Strombegrenzer. Soll ICH dir das in Großschrift schreiben oder vielleicht ein Buildl dazu malen? Himmelarschundzwirn...

scheint wohl so. Ich sehe hier nirgends einen Schaltplan mit mehreren parallel geschalteten LEDs mit gemeinsamer Strombegrenzung (also gemeinsamen Vorwiderstand).
Der Plan des TO hat da je LED einen:
http://forum.aquacomputer.de/index.php?p…dad07511afb8b27
Bei Sappi ist überhaupt keine Strombegrenzung zu sehen, was durch Verwendung von LEDs mit integriertem Vorwiderstand (also auch wieder jede einen) erklärbar ist:
http://forum.aquacomputer.de/index.php?p…750d412006bcced
Eheim1046->AD->CPU->NB->GraKa-APE240->AT AMD Sempron2500@2090MHz-K7VT4A+FSB333@380MHz-Maxtor80GB-Nvidia Geforce FX 5500

Sunday, April 22nd 2012, 9:20pm

Ich habe schon mehrmals diesen HDD-LED-Nachbrenner verbastelt, der funktioniert definitiv problemlos. Bei Knochenjonny halte ich daher den Eingangswiderstand R6 für überflüssig, das seltsame Poti am Eingang interpretiere ich als ohnehin nicht real vorhanden, oder?

@drdeath:
Ich finde Deinen Tonfall in diesem Thread auch wenig zielführend - erst oberlehrerhaft und dann motzig. Muss doch nicht sein...

Monday, April 23rd 2012, 9:11pm

So nu kommen wir mal alle wieder runter, es weiss doch jeder das niemand perfeckt ist.
Jeder normale mensch der NUR bischen e technik inner Schule hatte denkt halt im ersten Moment nicht daran das eine LED eben kein Ohmscher widerstand ist und ganz anders arbeitet.

Fakt ist das man pro LED ein Vorwiderstand zwingend verwenden sollte da sonst früher oder später alles kaputt geht. Zb. Kauf dir mal Paar LED Lampen aus China für 2 euro, die gehen eine Woche (maximal) dan sterben die reihenweise, und wieso ist das so ? Ja man wird es sich schon denken ^^ die netten herren aus dem reich der mitte waren einfach geizig und haben jeweils 20 LED's parallel geschaltet mit einem großen vorwiderstand, davon sind dann 4 solcher netzwerke zusammen in einem gehäuse untergebracht und juchu schneller als man will isses wieder dunkel xDD

Zu meiner Schaltung: Der Eingang am OK IST nur eine Bildliche Darstellung von dem wie ein Mainboard Anschluss arbeitet (es steht aber auch darunter als Text), es gibt keinen Mainboard Anschluss in irgendwelchen E Programmen zum simulieren (weder bei eagle noch bei multisim oder electronik workbench oder was auch immer) Diese verschaltung dient lediglich dazu um die Schaltung überhaupt virtuell zu testen, Der Eingang +5v und das Poti wenn es auf 0% ist wirkt als offener Schalter (vereinfacht) er verhindert in dem falle schlicht das irgend eine Potenzial differenz entstehen kann weil keine Verbindung zur masse besteht (ergo +5v am OK eingang und ungefähr +5V am Ausgang). Dreht man das poti nun höher zieht also den einen Eingang auf Masse (was jedes reale Mainboard auch macht, da gibt es kein + und - sondern eben nur ein Pin der bei aktiver platte negativer wird), somit entsteht zwischen den beiden Pins eine differenz der eine hat immer +5v der andere geht bei meinem board zb bis max 2v runter, differenz von 3 V, damit sollte jede LED leuchten, und damit die nich durchbrennen begrenzt das Mainboard von sich schon den Strom weil es eben eine Konstantstromquelle ist. Ergo denkt einfach den Eingang da weg wenn es euch Kopfschmerzen bereitet ^^ es dient nur zur simulation.

Achso, ich habe in einem IT Forum erfahren das ein Optokoppler wenn er den für eine solche Schaltung genutzt werden soll einen Vorwiderstand haben sollte. Ob der OK nun mehr oder weniger Strom abkann, niemand weiss welches ainboard wieviel Strom begrenzt bzw ausgibt, das macht jeder Hersteller nach eigenem ermessen, also wäre es sehr schlecht wenn man die Schaltung vllt universell einsetzen will und der strom eben dan nicht passt, vllt kann der OK auch durch seine toleranzen nicht soviel ab, ABER es ist eine Diode im OK und fast jede Diode sollte mit nichtmehr als 30ma betrieben werden (ausgenommen die superhellen) bei 60 ma würde das Ding vllt ne Woche durchhalten und dan gibt der OK nurnoch kurz rauchzeichen und stirbt xD

Iss doch egal welche Schaltung nu besser oder schlechter iss die ideale schaltung dafür gibt es ey nicht.

Ich wollte hier lediglich fragen ob das so funzt oder auch nicht weil ich total vergessen hatte wie mein Entwurf arbeitet, Mittlerweile weiss ichs wieder und ich bin der Überzeugung das meine Schaltung auch nach einem Jahr noch läuft ^^


EDIT: zu Limbachnet HDD Nachbrenner xD
Den käse von der Seite hatte ich auch ganz zum anfang mal gebaut (plus dem Sound to Light Modul welches ich viermal auf eine lochrasterplatine gebastelt habe mit zig potis um alles mögliche einzustellen und das dan in einen dvd schacht verfrachtet ^^)
Zum HDD Flasher, dieser funzt nur bedingt, der Transistor der da verbaut iss reagiert viel zu ungenau auf die HDD aktivitäten, wenn der ok nurn bisschen was schaltet dan glimmt und blitzt die led auf und ab wies gerade lustig iss, eben weil der Transistor keinen definierten Schaltung besitzt ^^ Peace Out

This post has been edited 1 times, last edit by "Knochenjonny" (Apr 23rd 2012, 9:15pm)

Thursday, April 26th 2012, 4:29pm

Der Vollständigkeit halber:

Bei allen Mainboards, die ich bisher in den Fingern hatte, sind die Laufwerk-LEDs digital angesteuert, also AN oder AUS. Auch die LED im Optokoppler ist dann an oder aus, irgendwelche Empfindlichkeits-Einstellungen gibt's dabei nicht, und beim Transistor schon gar nicht, deshalb funktioniert die Moddingtech-Schaltung bei mir in mehrfacher Aufführung prima.

Aber das heißt ja nicht, dass es keine anderen Schaltungsvarianten gibt, und wenn die Moddingtech-Lösung bei Dir nicht funktioniert, dann ist das eben so und Du musst etwas anderes basteln.

Ich hatte mal eine Netzwerk-LED in der Mainboard-Buchse integriert, die ich gerne an die Frontplatte kopieren wollte, da ging die bewährte Schaltung auch nicht. Irgendwie waren beide Kontakte der LED nicht vernünftig gegen Masse zu beziehen; also musste dort eine andere Lösung her - diese hier. Vielleicht kann ja noch jemand etwas damit anfangen.

Sunday, April 29th 2012, 11:59pm

Ein letztes mal geb ich hier noch meinen Senf dazu ^^ und dann lass ich es dabeu bewenden und bedanke mich für zahlreiche Ideen :)

Ein Mainboard HDD LED Anschluss arbeitet nicht digital, dort gibt es kein an oder aus, nehmt ein messgerät und prüft es nach.
Die Led wird immer mit einer analogen größe angesteuert deswegen glimmen sie manchmal und manchmal leuchten sie sehr hell, mit An oder Aus würde dies nicht gehen.

Zum Transistor, es ist ebenso eine falsche annahme das dieser nur an oder aus kann (der ideale transistor könnte das vllt)
Ein Transistor ist ein Bautail welches analoge signale in digitale umsetzen kann das bedeutet noch lange nicht das er es perfeckt macht (das würden die FETS können). Jeder Transistor hat eine Aus und Einschaltschwelle. Wirkungsweise eines Transistors ab rund 0,7 V wird er Leitend aber nicht 100%. Oft arbeiten Transistoren als Schalter (häufig auch als verstärker ^^), in dem hdd flasher haben wir nun also den OK der mit einer analogen größen von der fotodiode gefüttert wird, sollte die basis kollektor spannung nungerade bei 0,7 volt liegen fliesst zwar ein Strom aber es wird mit 100% sicherheit nicht der maximale sein, dem zu folge schaltet der transistor ein wenig , der zweite leistungstransistor danach bekommt dieses bisschen auch vllt macht er noch ne verstärkung (obwohl im linear betrieb die verstärkung immer 1 ist) und auch dieser transistor kann auf grund von toleranzen nur ne bestimmte schwelle erreichen, und darum ist es fakt das die LED's dann durch diese zwei transitor strecken derart verfälscht werden können das am ende einfach nicht das gewünschte bei raus kommt. (vllt glimmen sie dauernd und abundzu und leuchten garnicht auf oder wie auch immer) Die Schaltung kann muss aber nicht funktionieren.


Ende ^^

Monday, April 30th 2012, 12:29pm

Ach du liebe Güte!

Den Unfug kann man so nicht unkommentiert stehen lassen, am Ende glaubt's noch jemand... :rolleyes:

Also, dass ein Transistor nicht nur schalten kann, das stimmt natürlich. Die Erklärung der Wirkungsweise ist IMHO sogar ziemlich gut zusammengefasst und wäre mit Rechtschreibung und Satzbau versehen sogar lesbar. DIe Schaltung eines Transistors als Verstärker ist aber seit Jahrzehnten bekannt, danke für die Erinnerung, war aber nicht nötig. Nur - als analoger Verstärker muss der Transistor eben auch analog angesteuert werden und einen Arbeitspunkt mit Ruhestrom eingestellt bekommen und all sowas. Und das tun die hier vorgestellten Schaltungen allesamt nicht. Ob das nun ein realer oder idealer Transistor ist, tut dabei gar nichts zur Sache.

Dass die HDD-LED manchmal nur glimmt, liegt bei üblichen (!) Mainboards nicht an einer irgendwie analogen Ansteuerung, sondern an sehr schnellem An- und Abschalten, vergleichbar einer getakteten Ansteuerung wie sie z.B. auch bei einer Pulsweitenmodulation vorliegt. Das Glimmen geht mit "An" und "Aus" also ganz hervorragend. Um solche schnellen digitalen (!) Signale messen zu können, greift man mit "ein Messgerät" sauber ins Leere, das misst nämlich auch nur den gemittelten Effektivwert der Spannungspulse - und das auch noch falsch, wenn's kein True-RMS-Voltmeter ist. Das geeignete Messgerät an dieser Stelle wäre ein Oszilloskop, das hat aber nicht jeder herumzustehen (Ich hab' eins... :whistling: )

Es mag durchaus sein, dass es irgendwelche Mainboards gibt, die Frontplatten-LEDs glimmen lassen, ob nun über einen analogen Ruhestrom oder über eine PWM. Standard ist das aber nicht. Standard ist immer noch digitales "An" oder "Aus", nur eben etwas schneller.