• 24.02.2018, 03:05
  • Registrieren
  • Anmelden
  • Sie sind nicht angemeldet.


Problem with preassure readings of Aqualis XT 150 ml fill level sensor?

Sonntag, 17. September 2017, 20:31


I've just changed my loop's liquid. I'm using Mayhems Pastel Green, the same liquid as I used before in this loop. Just re-newed the liquid to maintain the loop's health.

I drained the loop, cleaned with Mayhems Blitz Part. 2 for 12 hours, cleaned again with distiled water 5 times (30 minutes loop runing with only pump each time), and filled with Pastel Green.

When I finally turn my system on, the reservoir MPS device showed 100% fill level, so I re-calibrated it. Everything seemed to work fine. I tried 30 minutes of stress test to see if the loop was proper cooling, and it did.

But after some time, my Aquaero started to beep indicating an alarm. I checked it and it shows "fill level alarm". I opened the case afraid of what I would find... but everything seemed to be OK, the reservoir has exactly the same level as I filled some hours ago. I restarted my PC and it worked fine for some time... but after that, the fill level alarm appeared again. And once again I checked that there were no level change at all.

So I checked in Aquasuite 2017.2 the reservoir MPS calibration page, it is selected as "MPS level sensor 40" device, and I've found that the "Current unescaled value" below the "Calibration curve" starts reading 735 while turning my PC on, but that number starts to descent with the PC turned. And it goes down till 27 currently (fill level reading shows 0%), but seems to me that it hasn't stoped yet and will continue descending.

Real fill level hasn't changed. And all the rest of readings in my system show normal numbers, flow reads with Aquacomputer High Flow shows and steady 125 L/h reading and temperatures of all my watercooled components are OK.

UPDATE: the current unescaled value finally reached 0. But it hasn't stoped it. That value continues going up and down... it doesn't stabilize in any value.

I suppose that the answer to this problem is a faulty MPS level sensor in my Aqualis reservoir. But just to be sure, am I doing something wrong or missing something?. I would like to know if there's something that I can check or do before being commited to change my reservoir (11 months old only). Is very dissapointing.

Thanks in advance.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josetortola« (17. September 2017, 22:43)

Montag, 18. September 2017, 04:27

I've been using the PC some hours, and this is what it shows now:

I've used Aquasuite data log to check what happens while using the PC with the MPS readings. And this is what it shows:

After reading zero some time, it started to go up once again while writing this post. So it seems that it will never stop.

I would like to think that maybe some kind of debriss or something like that is obstructing the MPS device, but don't know if it makes any sense at all. Maybe is just that my Aqualis reservoir MPS fill level sensor is dead, isn't it?.

That was incredibly fast, only 11 months since purchase. As reservoir it works, but I don't want to loose the fill level sensor, and RMA and send it back to Germany will make me loose my PC until arriving new one. Is really dissapointing, don't know what to do.

Thanks once again.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josetortola« (18. September 2017, 04:33)

Montag, 18. September 2017, 11:40

I have some news.

I've just tried to open my Aqualis reservoir top plug to add some liquid and see if the readings change. And when opening the plug, the unescaled value went to 355 and maintained.

Then I added some liquid and it went to 361 and maintained. Readings where totally stable.

So then I put the plug once again and as soon as I started to screw the plug, readings go up once again and very unstable.

So I removed the other plug, the pressure equalization membrane G1/4, and again, readings went to 361 and maintained stable. Then I visually checked the interior of the equalization membrane, and I have seen some green liquid detritus there.

Maybe when tilting the case to vent all the bubbles in the loop, some liquid reached the pressure equalization membrane and remained there until that trapped drops dryed, and the rest of the colorant somehow blocked the normal function of the membrane.

Is it possible?. And because a membrane not working raw pressure readings can go such crazy?.

Thank you very much.

Montag, 18. September 2017, 12:05

Your mistake was using colored fluid. Stick with clear and colored tubing with RGB leds if you want color. Not good for the sensors to say the least.

Montag, 18. September 2017, 13:35

Your mistake was using colored fluid. Stick with clear and colored tubing with RGB leds if you want color. Not good for the sensors to say the least.

Thanks for your answer.

I've used colored liquid since 5 years ago in 4 builds including this one, and never had any kind of problem at all until yesterday. No tube coloring, no obstructions, no sensor failure, no block's inner channels coloring... nothing at all until yesterday. And clear liquid + leds do not reach the same aesthetic results as coloured liquid.

So yes, maybe if I used clear liquid yesterday when I tilted my case, the liquid drop that entered in the equalization membrane plug and dryed there wouldn't obstructed the membrane. But I think that the problem itself was the liquid reaching the membrane because of tilting the case more than the liquid's colour itself. Next time I'll install the membrane after venting all the bubbles in the loop, will be the last plug to be installed in the reservoir.

Anyway, I'm still surprised about how a malfunctioning equalization membrane could affect the raw pressure readings in such a crazy way. I've cleaned it with water and a soft microfiber and it seems that it's working properly now. I'll continue checking it and will replace if it doesn't maintain normal readings.