• 23.08.2019, 00:26
  • Registrieren
  • Anmelden
  • Du bist nicht angemeldet.

 

Lieber Besucher, herzlich willkommen bei: Aqua Computer Forum. Falls dies dein erster Besuch auf dieser Seite ist, lese dir bitte die Hilfe durch. Dort wird dir die Bedienung dieser Seite näher erläutert. Darüber hinaus solltest du dich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutze das Registrierungsformular, um dich zu registrieren oder informiere dich ausführlich über den Registrierungsvorgang. Falls du dich bereits zu einem früheren Zeitpunkt registriert hast, kannst du dich hier anmelden.

Need Farbwerk Programming Help [SOLVED]

Mittwoch, 1. Juni 2016, 06:03

Need help with Farbwerk programming.

Involved components:
Aquaero 6XT
Aquasuite 2016-4
Farbwerk USB/Aquabus Version (connected to the Aquaero with both USB and Aquabus) Set to Aquabus Priority
CPU Temperature Probe (connected to Temp #1 on Aquaero)
RGB LED Strip attached to the Farbwerk

Goal:
To have the RGB LED output of the Farbwerk change colors based on the wired Temperature #1 input of the Aquaero.

Issue:
I cannot find out how to use the Aquaero Temperature #1 input to control the Farbwerk output.

I find that the Aquaero Software Temperature Sensors can be used, but not the wired Temperature Sensors.
I know that the Farbwerk itself has wired Temperature Sensor inputs, but I need the CPU Temperature Sensor connected to the Aquaero for the Fan Speed Controller.

I can monitor and export the wired Temperature Sensor with aida64, and then utilize the aida64 export as a Software Temperature Sensor for the Farbwerk, however when the computer is turned on this temperature reading is not available until aida64 and Aquasuite load.

I attempted to select "External controller source (aquabus, bluetooth, USB)" as the Farbwerk Controller input, but find no way of using the Aquasuite/Aquaero LED Controller as an input to the Farbwerk.

If anyone has successfully used an Aquaero wired Temperature Sensor as in input to the Farbwerk Controller, I'd like to know how you did it.

Thanks for any help.

RodeoGeorge

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »wa3pnt« (1. Juni 2016, 11:23)

Mittwoch, 1. Juni 2016, 09:10

As you already mentioned you have to change the mode of the channel to be controlled by an external source. The farbwerk must be connected to the aquaero via aquabus and in this case you can use the farbwerk as an output in the controller tab of the aquaero. You can add a RGB controller and assign the single color channels of the farbwerk to it.

Mittwoch, 1. Juni 2016, 10:04

As you already mentioned you have to change the mode of the channel to be controlled by an external source. The farbwerk must be connected to the aquaero via aquabus and in this case you can use the farbwerk as an output in the controller tab of the aquaero. You can add a RGB controller and assign the single color channels of the farbwerk to it.
Shoggy, let me step through what I'm doing and point out my error please.

1. Verify that the Farbwerk is connected to the Aquaero.



2. Set the Farbwerk Controllers (I'm using Channels 1 & 2) to be controlled via Aquabus




3. Open a LED Controller in Aquasuite that use a Temperature Sensor as input




4. When I select the output of the Aquasuite LED Controller (in this case I selected the RED LED Output), I do not see either Aquabus or the Farbwerk LED Strips as an option.





Thanks for your help.

RodeoGeorge

Mittwoch, 1. Juni 2016, 10:15

Are the strips showing any color as we speak while connected to the Farbwerk?

Btw, which tab is your #2 from? I don't have anything that looks like that. Is that the Farbwerk Tab on its own? Not in the Aquaero line up of tabs? If so, your Farbwerk hasn't given full control to the Aquaero yet.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »GTXJackBauer« (1. Juni 2016, 10:17)

Mittwoch, 1. Juni 2016, 10:34

Are the strips showing any color as we speak while connected to the Farbwerk?

Btw, which tab is your #2 from? I don't have anything that looks like that. Is that the Farbwerk Tab on its own? Not in the Aquaero line up of tabs? If so, your Farbwerk hasn't given full control to the Aquaero yet.
#2 is a snapshot of the Farbwerk Controller, when it is set to "External controller source (aquabus, Bluetooth, or USB)"

The strips are working fine using the output of the Farbwerk. If I set Farbwerk Controller 1 or 2 to "rotating Color" the LED Strips cycle through the colors.

RodeoGeorge

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wa3pnt« (1. Juni 2016, 10:35)

Mittwoch, 1. Juni 2016, 10:42

Can you take a image of the whole window on #2. I'm just mind boggled atm because I don't have anything that remotely looks like that in all of my tabs on Aquasuite 2016-4.

Mittwoch, 1. Juni 2016, 11:30

ISSUE SOLVED

Over on the OCN Aquaero forum, Jack posted a screen shot of his Aquaero LED Controller, which showed the options of selecting the Farbwerk LEDs as outputs.

This caused me to investigate why I could not see the Farbwerk LEDs, and I found that in the Aquaero>Outputs tab I had to set the Farbwerk outputs to "Use outputs from device"

This made the Farbwerk LEDs visible as an output from the Aquaero LED Controller.

RodeoGeorge

Mittwoch, 1. Juni 2016, 13:13

Good to hear. :thumbup:

Mittwoch, 1. Juni 2016, 18:03

george,bout time you farbed it lol,ill pm you tonight and help,with all help on my a6,its the least i can do


Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »barfly« (2. Juni 2016, 00:22)

Sonntag, 5. Juni 2016, 07:38

I do other way, from the aquaero I transfer temperature to the farbwerk as software temp, and then on the farbwerk I just have to select the software channel. I do this because my farbwerk read software temperatures badly by itself (reads value one second out of 5-10) but correctly of they are sent from the aquaero. So I do that for the CPU temp and one of my water temp.