• 08.12.2019, 17:56
  • Register
  • Login
  • You are not logged in.

 

Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Re: Aqua-Computer-City

Friday, July 4th 2008, 1:40am

tom - u have KN *nerv* :-*

Re: Aqua-Computer-City

Friday, July 4th 2008, 2:29am

Quoted from "Chris"

tom - u have KN

Ich schreib' das mal hier, weils mit den Linksys-Dingern warscheinlich noch mehr Probleme geben wird.
Für die wrt54xxxx Verwandten, sowie deren Ab- und Unterarten gibt's mehr (grundverschiedene) Firmware-Versionen als Dino Insekten aufzählen kann.

Da hilft nur brachiales Durchprobieren - das macht aber von Hand keinen Spaß.
Ich schreibe dazu noch eine Routine.

So ... ich bin leider bis Sonntag unterwegs und habe auch am Montag einen recht vollen Terminkalender.
Ich werde mich also erst wieder am Montag-Abend den Problemen widmen können.

mfg, Thomas

Edit: Vielleich ist ja mal einer der "alten RC-Hasen" mutig und testet, ob der RC hier funktioniert:
unserneuesprogramm.exe 0 1 A X ~\RouterControl.exe /D /Q
Vorher alles sichern und Programme schliessen - ein Absturz kann nicht ausgeschlossen werden.

Re: Aqua-Computer-City

Friday, July 4th 2008, 11:02am

Quoted from "Tom"



Edit: Vielleich ist ja mal einer der "alten RC-Hasen" mutig und testet, ob der RC hier funktioniert:
unserneuesprogramm.exe 0 1 A X ~\RouterControl.exe /D /Q
Vorher alles sichern und Programme schliessen - ein Absturz kann nicht ausgeschlossen werden.



"NameError: global name 'subprocess' is not defined"

sowohl Win32 als auch Python..

Re: Aqua-Computer-City

Friday, July 4th 2008, 11:47am

Entweder fehlt da ein ``import subprocess`` oder du verwendest eine separate Python-Installation vor 2.4. Dann würde es aber einen ImportError geben, daher tippe ich, dass Tom obige Zeile nur vergessen hat. Einfach mal - sofern nicht nur die .exe vorliegt - die Zeile in der Import-Sektion am Scriptbeginn ergänzen.

Re: Aqua-Computer-City

Friday, July 4th 2008, 12:32pm

Quoted from "Chris"

"NameError: global name 'subprocess' is not defined"

Grmpf - ich hasse Interpreter und Runtime-Linker.
Tippfehler und Vergesslichkeiten fallen erst auf, wenn das Programm (im wahrsten Sinne des Wortes) drüberstolpert.
Das kann sofort / irgendwann / nie geschehen.

... ist gefixt.

@Yogi - gibt's einen Parser/Profiler, der solche Fehler früher aufdeckt?
Dem PYinstaller ist es offensichtlich egal.

mfg, Thomas

Re: Aqua-Computer-City

Friday, July 4th 2008, 1:01pm

Quoted from "Tom"

@Yogi - gibt's einen Parser/Profiler, der solche Fehler früher aufdeckt?

Ja: Unittests.

Besonders einfach (gerade im Gegensatz zum Java-belasteten `unittest`-Modul der Stdlib) geht das z. B. mit nose. Dazu einfach zu einem exemplarischen Modul `foo.py` ein neues Modul `test_foo.py` anlegen. Darin das zu testende Modul importieren und einfach Funktionen mit Namen nach dem Muster `test_*` anlegen, die die Funktionalität des Importierten Moduls testen. Dabei reichen bereits `assert`-Statements, Exceptions können mit ``from nose.tools import raises`` erwartet werden.

Ein Aufruf von `nosetests` auf der Konsole sucht dann automatisch alle Testmodule und -funktionen und führt diese aus.

Re: Aqua-Computer-City

Monday, July 7th 2008, 11:07am

8400hits/tag

also entweder wir legen langsam mal wieder ne ganze ecke zu, oder wir können das ganze begraben....

Re: Aqua-Computer-City

Monday, July 7th 2008, 1:02pm

immer noch dabei

Re: Aqua-Computer-City

Monday, July 7th 2008, 2:40pm

Im Laufe dieser Woche sollte ich wieder einsteigen können. Dann sponsor ich wieder ein paar Hits.
[V] ASUS P7P55D Deluxe, unbenutzt und originalverpackt aus Garantieaustausch

Zitat von »FUNKMAN«

Liquid Sunshine in the Dark...

Re: Aqua-Computer-City

Monday, July 7th 2008, 3:02pm

bin ab morgen wieder dabei...
When you come across a big kettle of crazy, it's best not to stir it.

Muhahahahahaha, pwned du kacknoob!
*gockel gockel boaarrcck*

Re: Aqua-Computer-City

Monday, July 7th 2008, 4:21pm

vielleicht alle aus dem topic nochmal anschreiben ... einmal platz 1 sollte schon sein

@re@50

Foren-Inventar

Re: Aqua-Computer-City

Friday, July 11th 2008, 8:59pm

solangsam kommen wir wieder ran an platz2.

ich bin seit 3 tagen wieder 24/7 mit dabei. lohnt es sich die neue version zu nehmen? ich habe noch 40 die läuft einwandfrei.
Intel I7 4790K@4,9GHz | Gigabyte G1.Sniper Z97 | 16GB Teamgroup Vulcano Red 1866MHz | Asus STRIX 1070TI STRIX Advanced 2012MHz/4400MHz | Crucial M500 480GB | Coolermaster Silentgold 800W

Re: Aqua-Computer-City

Friday, July 11th 2008, 9:19pm

Quoted from "Tom"


Edit: Vielleich ist ja mal einer der "alten RC-Hasen" mutig und testet, ob der RC hier funktioniert:
unserneuesprogramm.exe 0 1 A X ~\RouterControl.exe /D /Q
Vorher alles sichern und Programme schliessen - ein Absturz kann nicht ausgeschlossen werden.



damit funktionierts wunderbar. allerdings nicht nur mit /D /Q, sondern mit /D /C /Q als parametern.

@re@50

Foren-Inventar

Re: Aqua-Computer-City

Monday, July 14th 2008, 3:34pm

Uuuuund wir sind Platz.2.
Intel I7 4790K@4,9GHz | Gigabyte G1.Sniper Z97 | 16GB Teamgroup Vulcano Red 1866MHz | Asus STRIX 1070TI STRIX Advanced 2012MHz/4400MHz | Crucial M500 480GB | Coolermaster Silentgold 800W

Re: Aqua-Computer-City

Monday, July 14th 2008, 3:55pm

und schön zu sehen, wie sich supernature und mynewbigcity gegenseitig pushen....
c++: The power, elegance and simplicity of a hand grenade.

maed

Full Member

Re: Aqua-Computer-City

Monday, July 14th 2008, 5:46pm

Hallo!

Gibt eigenltich jemanden der mit Netgearroutern und Tom's Programm arbeitet? Bei mir is nach kurzer Zeit Schluss....

MfG Hias
VERKAUFE: Aquatubeblende Alu, Aquaeroblende Edelstahl, Aquastream Controller Rev 3.0 FW1.31, 4x Patchpanel Cat6

Re: Aqua-Computer-City

Tuesday, July 15th 2008, 1:55am

Quoted from "area"

lohnt es sich die neue version zu nehmen? ich habe noch 40 die läuft einwandfrei.

Never touch a running system.

Es spricht allerdings nichts dagegen, "die Neue" mal auszuprobieren.
Da man für die 5er Version (im Normalfall) null und nichts installieren muss, kann man das ja mal testweise laufen lassen.
Ich wäre auch ganz froh um etwas FeedBack - sonst wird das Ding nie fertig.

Quoted from "Chris"

damit funktionierts wunderbar. allerdings nicht nur mit /D /Q, sondern mit /D /C /Q als parametern.

Wunderbar - Danke.
Damit hätten wir eine Variante, die ohne jegliche (Batch-)Programmier-Kenntnisse lauffähig ist.
RC installieren/einrichten - MakeRC ausführen - fertig.

Quoted from "maed"

Gibt eigenltich jemanden der mit Netgearroutern und Tom's Programm arbeitet? Bei mir is nach kurzer Zeit Schluss....

Ich habe für die Dinger noch keine brauchbare Idee - zumindest keine, die sich innerhalb des Programmes mit vertretbarem Aufwand realisieren ließe.
Vielleich möchtest Du mal testen, ob der mit RC besser zusammenspielen will.

mfg, Thomas

@re@50

Foren-Inventar

Re: Aqua-Computer-City

Tuesday, July 15th 2008, 2:12am

61951/568 meine statistik bisher. die nächsten 2 wochen läuft der rechner 24/7.
Intel I7 4790K@4,9GHz | Gigabyte G1.Sniper Z97 | 16GB Teamgroup Vulcano Red 1866MHz | Asus STRIX 1070TI STRIX Advanced 2012MHz/4400MHz | Crucial M500 480GB | Coolermaster Silentgold 800W

Re: Aqua-Computer-City

Tuesday, July 15th 2008, 10:07am

ich muss nochmal die optimale wartezeit rausfinden. 15sek ist eindeutig zu wenig. da funktionierts 8mal und danach bekomm ich keine IP mehr vom provider (oder kann das auch am Router liegen? WRT54GL).
um mal auszuschließen, dass der provider generell höchstens 10IPs am tag vergibt hab ich es heut nacht einfach mal mit 2min laufen lassen - da funktionierts wunderbar und es gab keinen fehler. aber 200hits/nacht ist bissel mager.

es hat nicht schon zufällig jemand erfahrung mit versatel/bornet als ISP?

Re: Aqua-Computer-City

Tuesday, July 15th 2008, 12:20pm

Quoted from "Chris"

ich muss nochmal die optimale wartezeit rausfinden. 15sek ist eindeutig zu wenig.

Was macht das Ding im Auto-Modus?

Quoted

da funktionierts 8mal und danach bekomm ich keine IP mehr vom provider (oder kann das auch am Router liegen? WRT54GL).

Das dürfte in aller Regel am Provider liegen.

Eine (einfache) IP-Block-Detection habe ich gerade nachgerüstet - Das Ding wartet dann selbsständig auf den nächsten Block.
Erkannt werden allerdings nur aufeinanderfolgende Dupes. Falls das zyklisch kommt, müsste ich den Teil noch etwas erweitern.

iirc bekam Shoggy die Adressen auch nur "häppchenweise".

mfg, Thomas