• 16.11.2019, 01:06
  • Register
  • Login
  • You are not logged in.

 

Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

SimonOcean

Junior Member

Aquaero 6 and USB D5 pumps

Monday, May 20th 2019, 11:12pm

I have 2x Aquacomputer's earlier generation Aquabus D5... they are not connecting properly, and I suspect that the Aquabus board is fried on each of them. They run, but only at full power. They are quite old now anyways and probably due replacing. What do people recommend nowadays? A few specifics about my requirements:

1) I have twin custom loops: Loop a) 480 rad and an EK CPU waterblock. Nothing else. Loop b) 560 rad and an EK GPU waterblock. Nothing else. My installation means that there is no room for Aquacomputer's D5 NEXT pump. Besides I don't like all the bling. (Please don't question me on room for the NEXT - I know there is not and I do not want to mod my case further to make room).

2) I've not been on the forums for a while, but I vaguely remember that the Aquaero 6 does not necessarily play nice with all D5 PWM pumps... am I correct in this? Are there any D5 PWM's that are known to be okay with the Aquaero 6? (I can easily and quick cheaply buy Primochill, EK or XSPC D5 PWMs).


3) Would you advice me to just forget PWM / Aquabus and get a Vario and set it to 3/5 or whatever. (Currently running at full speed the system is needlessly noisy and flow speed is unnecessary fast currently)?


Thanks for any advice fellow watercooling enthusiasts.

Bartdude

Junior Member

Tuesday, May 21st 2019, 6:17am

EK-D5 V2 PWM Pumps work fine, I use 2 myself
"no shit lady, does it sound like i'm ordering pizza?"

SimonOcean

Junior Member

Tuesday, May 21st 2019, 12:36pm

Ahh thanks BartDude, very helpful.

Bartdude

Junior Member

Tuesday, May 21st 2019, 12:37pm

Ahh thanks BartDude, very helpful.



Your welcome :)
"no shit lady, does it sound like i'm ordering pizza?"

Tuesday, May 21st 2019, 7:06pm

EK-D5 V2 PWM Pumps work fine, I use 2 myself


EK-D5 G2 (Generation 2) pumps since they've been redesigned to have intel spec PWM to work properly with controllers like the AQ.

I also have 2 of them in serial. Very quiet compared to my old DDCs 35X2 pumps.

This post has been edited 1 times, last edit by "GTXJackBauer" (May 21st 2019, 7:08pm)

SimonOcean

Junior Member

Saturday, June 8th 2019, 12:30pm

Thanks guys. Just got back from overseas trip: ordered. I should be able to get my system much quieter with the pumps at 50-60%.

GTXJackBauer: your the guy active on EVGA forums, right? Anyways, thanks for info.

Sunday, June 9th 2019, 7:44am

GTXJackBauer: your the guy active on EVGA forums, right? Anyways, thanks for info.


Yep, that's me.