• 27.09.2020, 22:21
  • Register
  • Login
  • You are not logged in.


Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Close the aquasuite before installation

Friday, December 13th 2019, 11:09pm

I've just bought Farbwerk 360 and RGBpx monitor kit, connected everything, started up PC, system discovered farbwerk 360, so next step I try to install aquacomputer software but everytime I try to run it it says "Close the aquasuite before installation". Never had to do with Aquacomputer software/hardware. I tried to delete the farbwerk 360 in Device Manager but it didn't help. I don't really understand what's going on. Any solution? I'm runing latest Windows 10 1909 x64.

This post has been edited 1 times, last edit by "don_dolarson" (Dec 13th 2019, 11:56pm)


Full Member

Saturday, December 14th 2019, 6:51am

strange but for to be sure:
can you check in taskmanager that really nothing from Aquacomputer is runing. Check under "Apps" and under "Background Services".

This post has been edited 1 times, last edit by "mditsch" (Dec 14th 2019, 6:52am)

Saturday, December 14th 2019, 8:25am

No, there's nothing, except the aquasuite.exe process which is triggered by the installation file. I've never had anything from Aquacomputer, so it's impossible there might be something. I'm using ProcessHacker to check running processes, drivers and services and Autoruns to double check and eventually disable from autorun but there's completely nothing.
I've tried to disable couple of programs like HWiNFO, Argus Monitor, MSI Afterburner, Kaspersky, Malwarebytes Anti-Malware, before running Aquasuite.exe. Tried to restart, run in compatibility mode Windows 8. Nothing. It won't install :S

Aquasuite installation.jpg

EDIT: I've just tried it on my laptop and the same shit is happening. The laptop is running Windows 10 1809. A proof has been attached below below.


EDIT: I've just tried to run it on a laptop of my friend and it works, but not detecting any Aquacomputer device. May I ask which service(s) does this software need to run? Maybe there's one which is disabled/stopped and need starting?

This post has been edited 13 times, last edit by "don_dolarson" (Dec 14th 2019, 9:00am)


Full Member

Saturday, December 14th 2019, 9:10am

The issue "close aquasuite.." is in my opinion then caused by a security option of Windows itself or from a third party security SW. For example "folder protections", "RAM protections"..

The issue that "nothing is detected.." is in my opinion caused by a problem with the USB connection or not having "power" at the AC devices.

This post has been edited 1 times, last edit by "mditsch" (Dec 14th 2019, 10:05am)

Saturday, December 14th 2019, 12:22pm

When it comes to security, all my hard drives and partitions on the desktop where farbwerk 360 is connected to (and 1st laptop) are protected and unlocked by BitLocker. I'm running Kaspersky Internet Security 2020 antivirus and Malwarebytes Anti-Malware on both machines. I've turned KIS and Malwarebytes off (along with couple of other software as stated above), AS TOLD BEFORE, but they don't affect the install process of Aquasuite. The problem "nothing has detected" was related to the 2nd laptop where I've tried to install Aquasuite on, just for troubleshooting it on a 3rd machine and I haven't seen the "Close the aquasuite before installation" message but could go a step further where I could see that there's no connected device which is logic. I appreciate your try to help, but I wish you start read my posts properly and not answering on stuff which I already told about... simple to not posting 100 pages and confuse anyone else who may have the same trouble in the future, as well as me, to not spend days back and forward or weeks to solve it.

Would like to hear from developer team of this software to know what service(s) or other librarie(s) needs to be installed/run.


Full Member

Saturday, December 14th 2019, 2:13pm

hello my friend,

I'm active in this forum since min 8 years now and during the last three years, very often, with several times a day and I read all new posts, because I'm interested in.
Never, but realy never I saw a post where another one was claiming the same issue and I guess Aquasuite is installed min onehundred-thousend times in the world.

And believe me, I read your posts very well and it was clear to me, that the USB problem was on another machine.

My answers were based on experiences of my self. in the past with another SW, were it was given same sounding error message and very, very often it was, because a security feature of the OS or third party SW was blocking snmething.
And I was not talking or thinking of Bitlocker, Windows does have a lot of another sec features..

but, do you know what: be my guest and I wish you the best in finding the issues on your systems .

Nice WE,,

Sunday, December 15th 2019, 5:42pm

I've solved the trouble myself.
It's very funny that YOU CAN'T CHANGE NAME OF THE AQUASUITE_SETUP to for example "AQUASUITE" otherwise it doesn't let you install it and push that (wrong) message. VERY FUNNY. You should write it with VERY BIG LETTERS on download page so everyone can see it, TO NOT CHANGE THE NAME OF IT.

This post has been edited 3 times, last edit by "don_dolarson" (Dec 15th 2019, 6:03pm)

Monday, December 16th 2019, 1:43pm

you have named you setup to: aquasuite.exe -> the aquasuite software runs also as aquasuite.exe.

Monday, December 16th 2019, 8:37pm

No, it won't install when the name of install package has been changed from it's original aquasuite_setup. I've tested it on 3 machines. I'm a bit disappointed of you as it took couple of hours for me to figure it out, before I was able to install it... such a stupid thing and no mention about not doing that, if it may be your piracy protection. You should know about that as you're developer of it and you wrote your application to work like that.

This post has been edited 1 times, last edit by "don_dolarson" (Dec 16th 2019, 9:09pm)

Monday, December 16th 2019, 10:54pm

What sebastian said was you renamed the installer the same name as the program it installs.
The installer tests that the aquasuite is not running prior to installing it, and requests you close it.

I renamed the installer to billybob.exe and it installed the aquasuite just fine.

Similar threads