• 29.05.2020, 21:24
  • Register
  • Login
  • You are not logged in.


Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Update firmware stuck on an new Quadro

Wednesday, April 8th 2020, 4:23am


This is a brand new system (MB: aorus Z390 I pro wifi) with a fresh install of Windows 10 and AquaSuite X.16. First time I launch the software, it recognized my Quadro but requested that I update the firmware. When I launch the firmware update, it stays stucked at 0% (over 20 minutes now). No activity on the device, fans are shutdown completely. Cooling loop is running as I connected the pump directly to the motherboard.

What can I do to figure out what is happening?



Wednesday, April 8th 2020, 7:15am

Power off your computer and try it again. Disable all other Moitoring Software. (Aida, HWinfo ...)

Wednesday, April 8th 2020, 1:51pm

I removed all software, including AquaSuite and powered off. This morning, I reinstalled AquaSuite and it did find again the Quadro. As it was still requesting a firmware upgrade to use with v. X.16, I launched the upgrade with the same result: stuck at 0% with message "The firmware of the device is outdated. Please perform an update. Without an update your device can not be used with this aquasuite version."

Task manager shows no active process (all below 1% CPU), no disk or network activity.

Some information on the device. Current firmware: 1011, serial number: 20951-42820.

Is there any log I can extract to get a hint of what is hanging the process?

When I launch the firmware upgrade, should I only have power + usb connected to the Quadro or is it OK to have fan + sensor too?

Wednesday, April 8th 2020, 2:11pm

try another USB port. This looks like an USB issue.

Wednesday, April 8th 2020, 2:41pm

I've tried the second header (pins 1,3,5,7) available on my motherboard with the same result as with the initial connection (pins 2,4,6,8). I confirm that both times, the red side of the Quadro connector was aligned with the +5V on the motherboard. I've attached the info from my MB manual of the USB header I'm using (F_USB1 (USB 2.0/1.1 Header).

After a failed attempt at firmware upgrade, the device is no more accessible (appears as disconnected in aquasuite). What is the fastest way to make it available again for an upgrade? Shutting down the computer for 10 minutes does not appear sufficient (overnight was).
s.lemieux has attached the following image:
  • usb_manual.png

Wednesday, April 8th 2020, 2:51pm

send a mail to info@aqua-computer.de
sound like your device is defect.

Wednesday, April 8th 2020, 3:14pm

Thanks for the rapid feedback. Email sent.