• 23.03.2023, 09:22
  • Register
  • Login
  • You are not logged in.


Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

High Flow USB

Wednesday, February 24th 2021, 3:21am

Hi guys, I have been running my AQ 6XT and my High Flow USB sensor for a little over a year now. I have had 0 issues, Just recently I purchased another High Flow USB to add into the second loop in my setup and I cannot get it to work over Aquabus.
My original High Flow Sensor shows up just fine.
I have both the USB Connection and a 3 pin Aquabus connected which is how I have always done it.

I have a feeling that I may have a defective High Flow USB sensor. It does not show up in my Flow Sensors tab on the Aquaero Software nor on my 6xt and it also does not show up on the Aquabus Tab in the software.

I have tried a few different 3 pin cables and I even have a second Aquaero 6xt here that it will not show up on either.

Is there something that I am missing that may have changed with the newer versions of Aquasuite?

Wednesday, February 24th 2021, 7:16am

have you a vilid flow rate when you connect the sensor via USB in the aquasuite?
You need a 4-Pin aquabus cable for the connection with the aquaero. You have to connect the sensor with aquabus connectors.

Wednesday, February 24th 2021, 7:26am

have you a vilid flow rate when you connect the sensor via USB in the aquasuite?
You need a 4-Pin aquabus cable for the connection with the aquaero. You have to connect the sensor with aquabus connectors.
Sorry about the quote reply issue.
The sensor reads over USB just fine, I have always ran them with USB connected and a 3 pin Aquabus cable connected to Aquabus high and it has always worked. Now for some reason it won't

This post has been edited 1 times, last edit by "sultan.of.swing" (Feb 24th 2021, 7:32am)

Wednesday, February 24th 2021, 8:01am

Power Off (remove the power cable) wait a few minutes and power on.
Perhaps the sensor is also defective.

Wednesday, February 24th 2021, 8:06am

I have done that more times than I can count now.
I bought a brand New 6xt that showed up today as my display got cracked on my other one from putting it in my drawer.
Still no dice.

This post has been edited 1 times, last edit by "sultan.of.swing" (Feb 24th 2021, 8:08am)

Wednesday, February 24th 2021, 8:53am

Describe in detail what is in your system and how everything is connected.
Apparently, the problem only occurred after you have rebuilt something.

Thursday, February 25th 2021, 2:43am

I changed my motherboard about a month ago from a EVGA X299 Dark to a Asus Rampage Extreme VI Encore.
RIght now the system is pretty basic, I have taken the dual loop setup out and am now just running a single loop and right now I am testing with just the 1 flow sensor.

Today I decided to make a 4 pin Cable for Aquabus and it still is not showing anything through aquabus either in the software nor on the Aquaero itself.

I just tried running the 4 pin into the header that says Flow 2 and I still do not get a reading for that either, I have never used that port before so I am not sure what all that entails to use that port.

It's pretty basic right now, Flow sensor is connected via USB and I have tried both a 3 pin (which used to work as that is all I used to use) and a 4 pin which I made today.

I have 2 other flow sensors here, 1 is a High Flow USB that does not read over USB and I have an MPS 400 that works just fine.
I will use the MPS400 and wire that in just to see if it can be seen over aquabus at all.

I just tried all 3 of my flow sensors, None of them will show up over Aquabus. I also tried on a whole different system that has never had aquasuite installed and they also will not show up over Aquabus on that system either.
Is there a way to download older versions of the software?

This post has been edited 1 times, last edit by "sultan.of.swing" (Feb 25th 2021, 3:48am)

Thursday, February 25th 2021, 9:21am

When you have connected the aquabus sensors not with aquabus -> aquabus you have destroyed the sensors.
MPS -> aquaero (aquabus)
High flow USB -> aquaero (aquabus)

Thursday, February 25th 2021, 3:55pm

I am not sure I am following what you are saying, the brand new high flow sensor I just bought last week and plugged in with both the USB and aquabus never worked over aquabus.
This is what prompted me to try and figure out why.

What you are saying is not having aquabus connected destroyed the sensors?

Saturday, February 27th 2021, 6:19pm

This is pretty annoying, I cannot get anything to work over Aquabus.

If all 3 of my sensors and 2 Aquaero 6XT's have faulty Aqaubus controllers I am not going to be happy.

Monday, March 1st 2021, 7:22am

Connect only one device with aquabus, and test it for each device.
Find out which devices are defective.

If a mistake was made in the wiring (wrong plug connection...) all devices that were connected at that time can be defective.
To 90% there is always a mistake from the user. This can be a faulty power supply or broken cable or something wrong connected.

Tuesday, March 2nd 2021, 4:34am

I've never connected anything incorrectly. I've been using my Aquaero for a few years now with USB and Aquabus connected so I am well versed on how it works.

I had my loop setup for 1 flow meter. That flow meter worked perfectly over aquabus and USB.

I added a second Flow meter along with separating the loop into 2 separate loops.

Original flow sensor still worked normally over USB and Aquabus. The second flow meter only worked over USB and not Aquabus.

I took the flow sensors out and now none of them will work over Aquabus, None of them even the original one that was working fine.

I mean the connections are pretty simple, USB and a 3 pin fan connection.

I don't know I am just a little aggravated because this flow sensor I bought that started all this mess I just bought 3 weeks ago. Now I am afraid to buy another one.


Junior Member

Saturday, March 6th 2021, 6:16pm

I think I may have the same problem like you. In my case the flow meter is not recognized by Windows as a valid USB device and it shows up with an error under Device Manager. It used to work perfectly before I decided to do a fresh install of Windows 10 Pro. ?(