• 05.02.2023, 10:57
  • Register
  • Login
  • You are not logged in.

 

Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Leaksheild stuffed up not releasing

Friday, November 25th 2022, 7:43pm

My Leaksheild is reporting my loop is secure, and it holds vacuum negative pressure for days at almost -400 mB.
Or does it?

I tried to release the vacuum in the release mode and it won't release.
Also i keep getting messages the pump is running too much or is not stopping, and I should report this to Aquacomputer

So, should I swap this out, clean the semipermable/oneway permable membrane or could this be a software issue?

Or this just sucks and suck and sucks?

:) :) :)
drdbkarron@gmail.com has attached the following images:
  • aquasuite_2022-11-25_13-32-32.png
  • aquasuite_2022-11-25_13-33-01.png
  • aquasuite_2022-11-25_13-37-58.png

Stephan

Administrator

Monday, November 28th 2022, 9:52am

Maybe the release valve got stuck or is not working properly. The membrane has no impact on the release as the release valve is conencted behind the membrane.
You can try to open your reservoir and release the vacuum manually. Then try again. Another option is to lightly tap against the LEAKSHIELD housing with a screw driver to release the valve.
Check the setup of your LEAKSHIELD. We suggest to do a fill level check once per week. This will allow the valves to be actuated regulary.
Of course there shouldn't be any issue even if you don't use them for a long time but as the rubber at the valve shaft is succed in the valve bore it will increase lifetime of the valve to change the postion over the time.