• 27.07.2021, 22:53
  • Register
  • Login
  • You are not logged in.


Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Junior Member

Farbwerk 360 - software bug - loses effect

Thursday, July 11th 2019, 8:59am

Hi all,
Yesterday I installed Farbwerk 360 into my PC. It is connected to USB separately from my Aquaero. Installed software is Aquasuite X.3 (latest version).
There is one reservoir RGBpx ring connected to output #1 and a set of 90 LED strips (6x 15 32cm strips) connected to output #2.

Both the reservoir ring and the large LED strip lighting have been set up to use an input data source coming off the Aquaero as a software sensor. The data source is a liquid temperature sensor located at the entrance into the radiator.

Thr Reservoir effect stops working randomly after a period between 30 seconds and 15 minutes. It cycles the colors for a while according to settings, then gets stuck on a color and stays there until I open Aquasuite again and navigate to the respective settings page shown above. Sometimes it starts working again as soon as I open the page, sometimes I have to uncheck and recheck the „control speed by data source” checkmark. Then, after a certain period of time, stops cycling colors again and I have to go back and open the settings page again.

Any idea on how to fix this behavior? It does the same even between restarts.


Junior Member

Saturday, July 13th 2019, 8:52pm

Anyone? I can't use any of my strips to display effects based on a sensor value. The effects stop after a while, no exceptions.

Sunday, July 14th 2019, 11:34pm

I do not have the farbwerk 360, but I do have a quadro, and I set a section of my rgbpx strips to run a color sequencer with roughly the same parameters as you did.
I saw the same thing as you, after a period the sequencer locked up while under the control of a data source for the speed.
When running the sequencer sans data source, it did not lock up for me.

Monday, July 15th 2019, 7:19am

We tried to reproduce this error, but everything works.

Do your software sensors update when the effect freezes?
Does this happen even if you use a different effect?

Monday, July 15th 2019, 2:45pm

The software sensor appears to be updating after the rgbpx strip ceases to change color.
It is the water inlet, so no large changes, but the decimal digits are updating in the LED Mapping panel.
Don't know if it matters, but the simulation strip at the top of the panel continues to update.

I have not tried other effects, but will do so. But first I will try a temp sensor plugged directly into a quadro temp input port.

Attached is the above setup with software sensor from water in, similar to war4peace.


Junior Member

Monday, July 15th 2019, 3:10pm

Hi all,

Interesting fact today.
After repeatedly failing to fix the issue, I had switched to an effect without controlling speed by data source (that was two days ago). The effect worked fine in the meantime by itself. Today, after @sebastian replied, I have switched back to having the same effect controlled by the software sensor (to replicate the issue once more). This was about 7 hours ago, and it still works for both strips, speed controlled. The only change I have made to my machine during this period was updating my nVidia Driver to latest version. Not sure if the two things were connected but worth mentioning.

I will continue to monitor and update this thread if needed.

Monday, July 15th 2019, 4:04pm

Thanks for the heads up war4peace.
I also had an nvidia update dated 2019.07.09 available, but did not have geforce experience installed and was unaware.
Will see if it helps. I had been seeing some display artifacts in-game recently, both may be related to a windows update around that time.
Hopefully this update fixes both issues.

Monday, July 15th 2019, 8:20pm

Several hours now, and no color sequence issues for me either after graphics driver update.


Junior Member

Friday, August 30th 2019, 7:22am

The issue resurfaced, unfortunately.
Yesterday I have received new goodies from Aquacomputer, namely more LED strips and another reservoir ring. I have installed a set of three 30-LED strips on top of my monitor (with more to come) and the reservoir ring on top side of my reservoir, so now I have one ring at the top and one ring at the bottom of my reservoir.
So I went in Aquasuite and extended the effect to cover both linked rings, and with that I have changed the effect from „Laser” to „Wave”. Surely enough, after a while the effect stops working by itself.
In Aquasuite I can still see the liquid temperature changing, but the LEDs no longer work. If I go and disable, then re-enable „Control Speed by Data Source” setting, the effect starts working again... for a while.
If I restart the computer while issue is ongoing (non-responsive LEDs), the issue is carried between restarts, prompting me to suspect something being wrong in Farbwerk 360 itself.
If I shut down the PC while the issue is ongoing, upon turning the PC back on the LEDs come back to life, so cutting power from Farbwerk resets the problem.
Out of the two Farbwerk outputs that are temperature-controlled, sometimes only one would stop working while the other would continue to work. Another thing: if both outputs are unresponsive and I disable/enable the temperature control setting on one of them, the other comes back to life too.
Before this, while there was no issue for Profile 1 since July, the issue was present for other profiles, so I have not used them, praying for Profile 1 to still work. And work it did, until I changed the effect.
Interestingly, the monitor ambient light strip works very well even while the temperature-based effects stop working.

I have taken a video capture of the issue, showing the Aquasuite interface, a stopwatch app and a webcam footage of th LEDs themselves. I will edit the video and upload it to youtube shortly, then update this thread.

LE: here is the video. The video is unlisted, meaning only those with the URL can watch it.


This post has been edited 1 times, last edit by "war4peace" (Aug 30th 2019, 7:44am)

Saturday, August 31st 2019, 8:23am

try to isolate the error

* set up only 1 controller that is active on alle 4 profiles
* connect a temperature sensor
* select this sensor as data source

is it possible that your profiles are chaned during your test run when the effect is stopping?


Junior Member

Saturday, August 31st 2019, 3:13pm

Thank you for your reply.
I have connected an Aquaero flat sensor to sensor input #1, set it up to Breathing effect, speed controlled by Sensor #1, for all profiles, all other controllers have been deleted. The flat tip of the sensor is outside the case, so I could easily control its data by taking it between my fingers and raise its temperature accordingly.
Now I will wait to see if the issue resurfaces and update here.


Junior Member

Monday, September 2nd 2019, 9:28pm

Update about this issue.

Step 1 was to delete all controllers and then create a controller which used 90 LEDs located in the case, with „Breathing” effect and speed controlled by an Aquacomputer flat temperature sensor plugged in directly into Sensor 1 of the Farbwerk 360. After a few hours of running, the effect ran just fine.
Step 2: I have created another controller which used 24 LEDs (2x reservoir rings in series located on the reservoir), with „Wave” effect and speed controlled by the same sensor mentioned above. This means that both controllers were using the same hardware sensor to control the speed. After a while, the second controller (the one created at this step) stopped working: the rings went dark. I was away from my PC for about 40 minutes after setting it up so the bug appeared between 5 and 45 minutes after the controller was enabled. Interestingly, the first controller kept working without a problem even while the second controller stopped working.
Step 3: I have disabled and re-enabled the „control speed by data source” on the failing controller and the effect started working for about 10 to 15 minutes, after which it failed again.
Step 4: I have changed the effect on the failing controller to „Breathing” (from „Wave”). After a couple hours, both controllers kept working without a hitch under the „Breathing” effect.
Step 5: I have changed the effect on both controllers from „Breathing” back to „Wave”. Less than 10 minutes afterwards, the secondary controller (the one with the 24 LEDs on the two rings) failed with the same symptoms (went dark). After a short while, the first controller went dark too.
Step 6: I have changed the effect on both controllers from „Wave” back to „Breathing” and left them overnight, the effects work flawlessly both using data from the hardware sensor as well as softwars sensor with data coming from Aquaero.
Step 7: Change the effect on both controllers from „Breathing” to „Rain”. The effect worked fine.

So then I started checking all effects in order:
- „Rotating Rainbow”: No bug.
- „Swiping Rainbow”: No bug.
- „Single Color” (control brighness by data source): No bug.
- „Color Shift”: No bug.
- „Color Change”: No bug.
- „Blinking”: No bug.
- „Color Sequence”: Controller #1 (Reservoir Rings) failed, stuck on RED color (RED to White was chosen as sequence) while Controller #2 continued to work. After disabling and re-enabling „control speed by data source” and deleting controller #2, controller #1 worked well for over 1h without issues.
- „Sequence”: No bug.
- „Scanner”: No bug.
- „Laser”: No bug.
- „Wave” (again): Bug replicated. Both controllers failed, locked to background color (black). After replicating the bug twice, I changed the sensor control setting from „speed” to „brightness”. Could not reproduce bug using this setting, so I switched back to „speed” and controller #1 failed after around 15 minutes, while Controller #1 kept working. I then configured both of them to follow both „Speed” and „brightness”, to see what is happening and unsurprisingly, controller #1 failed first.
- „Flame”: No bug.
- „Rain”: No bug.
- „Snowfall”: No bug.
- „Stardust”: No bug.
- „Color Switch”: No bug.
- „Bar Graph”: This one took a while due to its complexity, I have verified multiple configurations for it, including rotation control based on data source, with the same data source chosen. Still, it worked fine: No bug.
- „Time”: No bug.

- There seems to be a bug mainly linked to the „Wave” setting when it's configured to vary its speed based on a data source.
- The bug is present regardless of whether the data source is software sensor (coming from Aquaero) or hardware sensor (coming off Farbwerk 360 directly)
- Once the bug appears, it persists between restarts (if the controller goes dark, it stays dark during and after PC reboot), meaning that it would ignore the removal or reappearance of the data source, aquasuite software or aquasuite service. This prompts me to believe the bug is located within the Farbwerk 360 itself, rather than in the software.
- Once the bug appears, a system power cycle (shutdown/power up) makes it go away, leading me to believe the bug appears in an area on the device which needs power to work.
- Resetting the device to factory details does not fix the bug
- Based on controller #1 (with 24 LEDs) always failing before controller #2 (with 90 LEDs) I assume the bug could be in close relation to effect cycle count.
- Based on not being able to reproduce the bug using „brightenss” configuration, only „speed”, it seems to be triggered by speed variation changes.

Note: all controllers were set up to be active for all profiles. The profile which was active during the entirety of troubleshooting was profile #1. Temperature range for speed control was configured for the same values for all controllers and all effects as 20 to 40 degrees Celsius unless otherwise specified.

I hope this helps narrowing down the issue.

Tuesday, September 3rd 2019, 8:50am

- „Color Sequence”:
- „Wave” (again): Bug replicated.
Thank you for testing.
I can confirm that this 2 controllers have an problem and with the next update the issues are fixed.


Junior Member

Tuesday, September 3rd 2019, 8:53am

Thank you!