• 21.04.2019, 12:19
  • Register
  • Login
  • You are not logged in.

 

Dear visitor, welcome to Aqua Computer Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Wednesday, July 18th 2012, 2:19pm

Hallo,

ich habe das alles hier ganz aufmerksam gelesen und möchte fragen, ob mir jemand soetws für kleines Geld bauen kann.
Auf meinem MoBo (ASRock X79 Extreme4) ist auch nur ein HDD-LED Anschluss und dieser ist schon für die Systemplatte belegt.
Was ich gerne möchte:
Ich habe zwei Wechselrahmen mit SATA-Platten, die jeweils mit einer LED für den HDD-Zugriff ausgestattet sind (2 PIN Stecker).
Diese LED sollen jeweils einzeln angesteuert werden.

Über eine Antwort würde ich mich freuen.

MeeooW

Senior Member

Monday, July 23rd 2012, 11:41pm

die haben jeweils sschon ne LED und die blinkt entsprechend des zugriffs am jeweiligen rahmen? ... und was willst du nun genau? check ich nciht erklär mal kurz ich steh aufm schlauch

This post has been edited 2 times, last edit by "MeeooW" (Jul 23rd 2012, 11:45pm)

Tuesday, July 24th 2012, 8:55pm

Hallo,
ja, die haben jeweils eine LED, aber die können nicht blinken, weil ich sie doch nirgendwo anschließen kann. Das ist das Problem.
.... weil doch auf meinem Mainboard nur ein HDD-LED Anschluss ist und dieser ist für die Systemplatte belegt.

Und jetzt möchte ich, dass die zwei Wechselrahmen jeweils einen HDD-LED Anschluss bekommen.... und so etwas müsste gebaut werden.

hugoLOST

Foren-Inventar

Tuesday, July 24th 2012, 9:35pm

Der HDD-LED Anschluss auf dem Board ist nicht nur für die System HDD sondern für alle HDDs/SSDs im System (woher soll das Board auch wissen was deine System Platte ist).
Intel I7 4790K@4,9GHz | Gigabyte G1.Sniper Z97 | 16GB Teamgroup Vulcano Red 1866MHz | Asus STRIX 1070TI STRIX Advanced 2012MHz/4400MHz | Crucial M500 480GB | Coolermaster Silentgold 800W

Wednesday, July 25th 2012, 9:05am

Darum geht es doch gar nicht.

Mal die ganzen vorherigen Beiträge auf der Seite 1 gelesen?

Da wurde soetwas gebaut und genau darum geht es.
(....die können nicht blinken, weil ich sie doch nirgendwo anschließen kann)

drdeath

Senior Member

Saturday, July 28th 2012, 10:56pm

Geht. Guckst du hier: http://www.hardwareluxx.de/community/f14…eht-578319.html Und nächstes mal selber Googeln.
Hier geht's zum RGBAmp
Hinweis: Der RGBAmp stammt nicht von AC und wird nicht offiziell supported!
Note: The RGBAmp is not an AC product and isn't officially supported.

Monday, July 30th 2012, 11:48am

Und was soll das jetzt?
Habe ich gefragt, ob es geht oder nicht geht? Die Frage lautete doch anders, oder?
Wer sagt denn, dass ich den Link, den du mir gibst, nicht kenne?
Der ist aus 2009... und diese Beiträge aus 2012....
Und, was meinst du, wie bin ich hier her gekommen? Mit Google oder mit dem Fahrrad?
Gib dir beim Lesen etwas Mühe, auch wenn es dir schwer fällt.

drdeath

Senior Member

Friday, August 3rd 2012, 11:48pm


und möchte fragen, ob mir jemand soetws für kleines Geld bauen kann.
[...] Ich habe zwei Wechselrahmen mit SATA-Platten, die jeweils mit einer LED für den HDD-Zugriff ausgestattet sind (2 PIN Stecker).
Diese LED sollen jeweils einzeln angesteuert werden.
Und was soll das jetzt?
Habe ich gefragt, ob es geht oder nicht geht? Die Frage lautete doch anders, oder?
Wer sagt denn, dass ich den Link, den du mir gibst, nicht kenne?
Der ist aus 2009... und diese Beiträge aus 2012....
Und, was meinst du, wie bin ich hier her gekommen? Mit Google oder mit dem Fahrrad?
Gib dir beim Lesen etwas Mühe, auch wenn es dir schwer fällt.

Quoted

Über eine Antwort würde ich mich freuen.
Ohne Worte...

www.ebay.de/sch/?_nkw=sata hard drive activity led adapter

Druckfrischer Link, garantiert aus 2012, mit besten Empfehlungen von Doc's Googleservice, nicht gesponsert, gefördert oder unterstützt von www.gidf.de
Hier geht's zum RGBAmp
Hinweis: Der RGBAmp stammt nicht von AC und wird nicht offiziell supported!
Note: The RGBAmp is not an AC product and isn't officially supported.

Saturday, May 28th 2016, 4:00pm

Standard ist das aber nicht. Standard ist immer noch digitales "An" oder "Aus", nur eben etwas schneller.
Hallo Limbachnet,

ich krame mal diesen alten Threat wieder hoch, zu Deiner obigen Aussage folgende Frage:

Wo sitzt denn das digitale Bauteil, das für "An" oder "Aus" sorgt, vor oder hinter der angesteckten LED?

Wenn es dahinter sitzt, könnte man dieses doch für einen zusätzlichen Stromkreis nutzen, solange da nur EINE zusätzliche LED angesteuert werden soll, also max. 40mA fliesen, oder?

Beispiel:

Ich zapfe an einem Molexstecker +5V ab, löte dort eine Vorwiderstand an, vom Vorwiderstand geht es zur Anode der LED, von der Kathode der LED auf den Minuspol der eigendlichen HDD LED Pfostenstecker.

Somit kann ich die Gehäuse HDD LED weiterhin ans MoBo anklemmen und habe einen zusätlichen Stromkreis mit einer zusätzlichen LED, die genauso blinkt oder glimmt, wie die Gehäuse LED.

Aber wie gesagt, die digitale Schalteinheit muß dann statt 20mA für eine LED 40mA für 2 LEDs aushalten, vielleicht ist diese damit schon überfordert.

Wer kann mir dazu Auskunft geben?

Irgendwo habe ich gelesen, das der Minuspol der Pfostenstecker geschaltet ist, deswegen komme ich auf diese Idee, die Seite finde ich aber nicht wieder, vielleicht ist das auch von Board zu Board unterschiedlich.

Gruß Unforced

Saturday, May 28th 2016, 6:06pm

Ob das bei allen Mainboards gleich gelöst war - und immer noch ist - wird Dir hier keiner sagen können. Auch deswegen, wurde damals ja die vorhandenen LED durch einen Optokoppler ersetzt (der primärseitig nichts anderes als 'ne IR-LED ist).
Primärseitig die vorhandene LED zu lassen UND parallel dazu 'ne weitere anzulöten, wär mir zu riskant.
Entweder nur der Optokoppler ans MoBo und die vorhandene LED mit der/den zusätzlichen LEDs (mit je eigenen Strombegrenzungswiderständem) sejundär an den Koppler,

ODER

mithilfe eines Komparators die an der vorhandenen LED abfallende Spannung hochohmig abgreifen und "verstärken" -> siehe Limbachnets Beitrag.
Eheim1046->AD->CPU->NB->GraKa-APE240->AT AMD Sempron2500@2090MHz-K7VT4A+FSB333@380MHz-Maxtor80GB-Nvidia Geforce FX 5500

Saturday, May 28th 2016, 8:02pm

mithilfe eines Komparators die an der vorhandenen LED abfallende Spannung hochohmig abgreifen und "verstärken" -> siehe Limbachnets Beitrag.
Hallo LotadaC,

erst mal danke für die schnelle Antwort, aber, zum Komparator finde ich in diesem Threat keinen Beitrag, auch die Forensuche ergab nur zwei Treffer, und die haben nichts mit diesem Thema zu tun, aber vielleicht kannst Du mir noch mal erklären was Du meinst.

Zum Thema Optokoppler, warum kappiere ich nicht, wofür die beiden Widerstände R1 und R2 und der Transistor da noch nötig sind, kann man nicht mit dem Sekunderausgang des Optokopplers einen x- beliebigen Stromkreis öffnen und schließen? (das ist doch eine Fotozelle, die auf die LED reagiert, oder nicht?)

[img]https://forum.aquacomputer.de/index.php?page=Attachment&attachmentID=3012&h=197cf13332fcc0510711e5806750d412006bcced[/img]

Noch mal zu meiner Theorie, ich hab gerade mal einen alten P3 Rechner (ich schmeiße ja nichts weg :P) aufgemacht und geprüft, ob der Minuspol der HDD LED Postenstecker durchgang zu Masse hat, dem ist nicht so, wenn der Stromkreis vor der LED geschaltet wird, müßte ja der Minuspol einfach auf Masse gelegt sein, oder? Das heißt, bei diesem uralt Board müßte meine Theorie zumindest funktionieren.

Wenn ich das jetzt an meinem aktuellen Rechner prüfe, dürfte doch eigendlich nichts kaputt gehen, wenn der Rechner aus und von der Steckdose getrennt ist, oder? Bei der Durchgangsprüfung wird ja keine Spannung angelegt.

Gruß Unforced

Saturday, May 28th 2016, 10:57pm

Die alternative Schaltung mit Komperator erwähnt Limbachnet in Beitrag 18. Dabei liegen die Eingänge eines Komperators quasi parallel zur vorhandenen LED. Wenn die LED leuchtet, fällt an ihr eine Spannung zwischen 1,fragmichnicht bei rot bis 3,hastenichtgesehn bei weiß/blau ab. Diese Differenz liegt auf den Komparatoreingängen, also schaltet der seinen Ausgang von seiner Negativen Versorgungsspannung (=Gnd) auf seine positive Versorgungsspannung um.
Im Gegensatz zur Optokopplervariante hast Du keine galvanische Trennung mehr, dafür läßt sich das aber auch an Gegebenheiten anpassen, wo der Optokoppler versagt, weil zB der Strom zu gering ist ('ne Indikator-LED kann ja durchaus auch auf ein halbes mA dimensioniert sein...)

Zu "den Widerständen und dem Transistor": Der verwendete Optokoppler scheint nach meiner damaligen Aussage 50mA sekundär zu vertragen. Wenn diese (zB durch mehrere parallelgeschaltete LED (-stränge) oder eine LeistungsLED) überschritten werden, muß eben ein leistungsfähigerer Transistor/MOSFET dahinter.
Prinzipiell könntest auch einen Transistor über einen Spannungsteiler zwischen die beiden Anschlüsse am MoBo klemmen. Allerdings wären für beide Varianten (Schaltung erfolgt Anoden- oder Kathodenseitig) unterschiedliche Schaltungen nötig.

Bei den alten IDE-Anschlüssen (parallelATA) sollte sich dasselbe Signal eigentlich auch an Pin39 abgreifen lassen (schaltet bei Aktivität auf Gnd durch).
Bei seriell-ATA könnte man theoretisch auch mit'nem Komperator die Potentialdifferenz zwischen den beiden differentiellen Sende- oder Empfangssignalen auswerten - wär mir allerdings zu heikel...

Zu Deinem Test:
Im einfachsten Fall hast Du an einem der beiden Anschlüsse einen Widerstand gegen einen Pol der Spannungsversorgung, am anderen einen Transistor/MOSFET gegen den anderen Pol.
Am wahrscheinlichsten einen 470Ohm zwischen 5V und Anodenpin, einen NPN-Transistor zwischen Kathodenpin und Masse. Das muß aber nicht zwingend so sein. Statt des einfachen Widerstandes kann eine komplexere Strombegrenzung verwendet werden, statt des LowSide-NPN ein PNP/High-Side-FET...

This post has been edited 1 times, last edit by "LotadaC" (May 28th 2016, 10:59pm)

Eheim1046->AD->CPU->NB->GraKa-APE240->AT AMD Sempron2500@2090MHz-K7VT4A+FSB333@380MHz-Maxtor80GB-Nvidia Geforce FX 5500

Saturday, May 28th 2016, 11:23pm

Zu Deinem Test:
Im einfachsten Fall hast Du an einem der beiden Anschlüsse einen Widerstand gegen einen Pol der Spannungsversorgung, am anderen einen Transistor/MOSFET gegen den anderen Pol.
Am wahrscheinlichsten einen 470Ohm zwischen 5V und Anodenpin, einen NPN-Transistor zwischen Kathodenpin und Masse. Das muß aber nicht zwingend so sein. Statt des einfachen Widerstandes kann eine komplexere Strombegrenzung verwendet werden, statt des LowSide-NPN ein PNP/High-Side-FET...
OK, das ist jetzt zu hoch für mich ?(

Gruß Unforced